On Sat, May 28, 2005 at 10:27:26PM -0400, McAfee wrote:
> Michael Schumacher wrote:
> >McAfee wrote:
> > 
> >
> >>I have the latest versions of libjpeg, libpng, libtiff and libXpm
> >>installed with LD_LIBRARY_PATH set accordingly.  I also downloaded and
> >>installed gimpprint, and gimp-help.
> >>
> >>After three compile attempts...
> >>
> >>1) I still cannot save in any other format other than .xcf
> >>2) There is still no 'file/print' menu option
> >>3) The help-browser module still doesn't get built
> >>   
> >>
> >
> >Did you mix different versions of GIMP?
> > 
> >
> No. I had to do some housecleaning for these directories...
> /lib
> /usr/local/lib
> /usr/sfw/lib
> /opt/sfw/lib
> ...
> what a mess!
> I tried to delete all Gimp1.2 dependencies (without breaking anything 
> else).  I seem to have been successful in that, but I may have missed 
> something.  Gimp2.6 gets built and looks great with GTK but I just 
> cannot determine why I cannot get it to open/save png, tiff, jpeg files, 
> build the help-browser, nor print!!!
whatever gimp-1.2 depends on should not affect gimp2 dependencies.  the
advice was to look for other instances of gimp-2.something on your
computer.  if the build process finds things in /usr/ it will not look
for things in /usr/local/ or where ever you might have things at.

i suggest that you watch the configure messages very carefully; it gives
you a lot of information.

gimp print is a separate package.

> Does CUPS need to be installed for gimpprint to work (I don't think so 
> but thought I'd ask)?
> I'm lost here?
it is a separate package and it should also give helpful information
either via the INSTALL file or via the configuration spew.

take a deep breath, relax and read the spew ....

> Thanks for any help.
once the problems are taken care of and if you continue with gimp
logically you should never have these issues again.


Gimp-user mailing list

Reply via email to