Bram Van Steenlandt wrote:
> Hi list,
>
> I run FreeBSD 6.2 (2 gig ram)  and use gimp-2.2.17 for editing my large 
> (10000x10000pixels) photos.
> This works when the tile cache is set to 256MB but this is not enough 
> for fast editing.
> When I set the tile cache to 512MB or more it stops with error:
> GLib-ERROR **: gmem.c:135: failed to allocate 16384 bytes
> I checked in top while the gimp was opening the image and I still had 
> 400MB free before it stopped (not counting my 4000MB free swap).
>   
After asking the gnome/freebsd guys some nice person said I should try 
adding kern.maxdsiz=1073741824 to /boot/loader.conf and reboot.
This worked, the gimp now opens the large files when the tile cache is 
set to 512MB, editing is the same speed as fedora.

turning off the layer preview things also helped a lot.

I tried krita but it crashed when  I asked to do a 90 degree turn.

nip2 opened the files ok but it's kind of a strange program to work with.

thanks all for the answers
 
_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to