Thanks for all of the help!  I don't really have any direct suggestions for
why there would be a problem with the git clone.  There is a limitation
that I ran into with testing which was the index.htrw files work almost
like an index.html file would except it did not seem to follow the links
completely.  For example the 'index.htrw' file under tutorial references
the directories that hold all of the tutorials:
<a href="Basic_Scheme/">GIMP Script-Fu</a> Write Scheme for GIMP.
<a href="Basic_Scheme2/">GIMP Script-Fu 2</a> Write More Scheme for GIMP.
<a href="AutomatedJpgToXcf/">Automated Jpg to Xcf</a> Import Xcf Images a
Directory at a Time.
All of these links simply showed a directory of files in the index.htrw, I
just followed the same pattern as the existing tutorials.  I concluded that
there is a downstream process that defines the styles, fonts, colors, and
how to follow the links.  My conclusion could be wrong, but I did not see
how to display any of the gimp web with the same 'look' as I see on the
gimp web site.

Just to be sure I was clear with my intent, there should have been the
following in the share export_to_gimp_web

[stephen@localhost export_to_gimp_web]$ ls -R
AutomatedJpgToXcf  index.htrw

./AutomatedJpgToXcf:  gimp_jpg_to_xcf_popup.jpg  gimp_menu_compare.jpg
index.htrw  script-fu-example-jpg-to-xcf.scm

The directory AutomatedJpgToXcf and file index.htrw should go into
gimp-web/tutorials.  The index.htrw would replace the older index.htrw and
has a link to the new tutorial in AutomatedJpgToXcf.  There are index.htrw
files in several places, just wanted to be clear about which I was trying
to modify.

I am not sure if I addressed your questions or issues or not.  As I said
there are some limitations to what I was able to test, I did try to stitch
my tutorial into the tutorials section following in the same technique as
the existing tutorials.  I do appreciate your testing the changes, I would
hate to be know as the guy who broke everything.

I am going to be leaving in a few minutes and will be on the road for about
a week.  I will have very limited access to the internet, so perhaps if
there is something that I need to fix, I can look at it next week.

Thanks for the help and suggestions.

Stephen Kiel

On Wed, Jul 24, 2013 at 2:59 AM, Marco Ciampa <> wrote:

> On Tue, Jul 23, 2013 at 07:32:57PM -0700, Stephen Kiel wrote:
> > I did format the tutorial into web format
> Here you can help me a lot. I have tried to test your tutorial before
> committing it to the git-web repo but I was unable to test it.
> I have started with trying to test the actual web site without any
> additions directly from a git clone command. I have tried both with
> makefile and with Apache SSI directly.
> Same results: it keeps to create into the git dir a bunch of html files
> and install just a few of them into the right installation dir.
> There must be something wrong here.
> I use Linux Ubuntu 13.04 wich comes with python-2.7 (could be a problem
> the python version?)
> Any hint?
> --
> Marco Ciampa
> +--------------------+
> | Linux User  #78271 |
> | FSFE fellow   #364 |
> +--------------------+
> _______________________________________________
> gimp-docs-list mailing list

Stephen Kiel
26602 Strafford
Mission Viejo, CA 92692
*Mobile/SMS (949) 702-1993*
Home (949) 367-2915
gimp-web-list mailing list

Reply via email to