On Wed, Jul 18, 2012 at 04:10:19PM -0700, Bart Baker wrote:

> I apologize if this is a repeat post, but I haven't been able to find this
> issue referenced. I'm running git on Ubuntu 12.04. Most of the commands work
> fine, but I'm having trouble with git diff displaying any output. If I run:
> 
> $ git diff
> $ 
> 
> on a repo that definitely has changes, I do not see any output. If instead
> I run:
> 
> $ sudo git diff
> 
> I get the expected git diff output, spread over multiple pages. I installed 
> git
> using apt-get, but there seems to be some sort of permissions error. Is 
> there
> a certain git core file that I need to change the permissions on?
Try running `git diff` so that is sees the GIT_TRACE environment
variable set to 1, and post the output here.
Like this:
$ export GIT_TRACE=1
$ git diff

Do the same for the sudo case; but this should be handled differently
(since, I think, sudo might sanitize the environment):
$ sudo su
...
# export GIT_TRACE=1
# git diff

You can then try to compare what gets called in each case.

Another question: do you have the PAGER environment variable defined?
IOW, what does
$ echo $PAGER
output?

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
git-users+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/git-users?hl=en.

Reply via email to