Jeffery Brewer (Mon, Aug 06, 2012 at 07:57:13PM -0700) >>
> I've slowly been trying to get git to work and just running into loads of 
> problems.
> Using the windows bash I just tried to do a commit this evening and forgot 
> to add a message (e.g. -m "my work for today") and sent the bash into some 
> sort of odd editing mode that I can't seem to get out of. I finally just 
> closed the bash and opened a new bash and tried to commit and got all kinds 
> of error messages with a prompt to type (R) to recover. Typed R to recover 
> and it took me right back into the strange editing mode that I can't seem 
> to get out of now. I've backed up all the files in the directory (sensing 
> an impending catastrophe) but not sure what else to do at this point to get 
> git running again. 
> Any help would be appreciated.

The default editor for git is vim, which is a sensible choice as its
available on nearly every platform, but if you've never encountered it
before it can seem a little... unusual.

A little more information on it is at the wiki page here:
And an introduction to its use can be found here:
    (First hit on google; I haven't read it so can't vouch for its quality)

The gist of it is: Press "i" to enter "insert" mode, which will let you
type.  Press "esc" to exit that mode.  In "normal mode" (after pressing
esc) type ":wq" to write your changes to file and quit.

> More detail...
> If I open a new bash in the directory and run "git commit" I'm getting this 
> error message:
> Found a swap file by the name ".git\.COMMIT_EDITMSG.swp"
>              dated: Mon Aug 06 19:45:14 2012
>          file name: 
> C:/Users/me/Documents/NetBeansProjects/foldername/.git/COMMIT_EDITMSG
>           modified: YES
>          user name: me   host name: my computer
>         process ID: 10368
> While opening file ".git\COMMIT_EDITMSG"
>              dated: Mon Aug 06 19:55:29 2012
>       NEWER than swap file!
> (1) Another program may be editing the same file.
>     If this is the case, be careful not to end up with two
>     different instances of the same file when making changes.
>     Quit, or continue with caution.
> (2) An edit session for this file crashed.
>     If this is the case, use ":recover" or "vim -r .git\COMMIT_EDITMSG"
>     to recover the changes (see ":help recovery").
>     If you did this already, delete the swap file ".git\.COMMIT_EDITMSG.swp"
>     to avoid this message.
> Swap file ".git\.COMMIT_EDITMSG.swp" already exists!
> -- More -- SPACE/d/j: screen/page/line down, b/u/k: up, q: quit

These warnings are vim warnings and not git ones.  They're telling you
that vim ended unexpectedly (when you force-closed the window) while you
were editing a file, so there's a backup you can recover.  Clicking
recover opens the backup so that you can edit it again.

Having said all this, you can change the text editor using the following

    git config --global core.editor "notepad"

Obviously changing "notepad" to something more sensible first(!)

Vim is a very good editor and I recommend learning it.  I believe the
"Cream" distribution is popular with Windows people:


It is an entirely separate thing from git however, and there is an
argument for learning the two tools separately, in which case perhaps
changing the editor to something you're more comfortable with until you
feel happy with git would be a good idea.


You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to