Thanks for the suggestion.  I remember running into the missing perl 
modules problem early on.  I was able to find those modules and put them 
where they belong and get past that particular problem.  So anyhow I 
uninstalled 1.17.11 and installed 1.7.10 only to see the same scenario I 
described before: git repository initialized, nothing else but a $ prompt 
and git show errors.  I found this post, 
http://solidgone.org/Migrate-from-Subversion-to-GIT-on-Windows, which leads 
me to believe I'm doing something wrong with the svn:// protocol.  
Actually, I get different errors when I try svn://.  With the situation I 
described earlier, I was using file:// instead, which was taking me farther 
without errors but ultimately getting me nowhere.  Even though this, 
https://bbs.archlinux.org/viewtopic.php?id=58385 is aimed at Linux users, 
it looks like it has clues that I can translate to my Windows environment.  
I'm going to try that this morning.  If that fails, unless someone has the 
answer and posts it here, I'm going to punt.  I'll just take a local source 
folder, convert it to a git repos, and then push that up to a remote git 
repos on projectlocker.  If I can accomplish that today, there's a cold 
beer with my name on it and a long weekend ahead that I plan to enjoy 
thoroughly.  Happy Labor Day and thanks again!

On Thursday, August 30, 2012 5:07:40 PM UTC-5, Peter J Weisberg wrote:

> On Thu, Aug 30, 2012 at 2:30 PM, Scott Anderson 
> <sand...@fourhands.com<javascript:>> 
> wrote: 
> > Has anyone had any success with 'git svn clone' on Windows?  I'm new to 
> git. 
> > We've been using subversion and I've been elected to migrate our 
> existing 
> > projects to git.  I'm using version 1.7.11-preview20120710 and I'm 
> following 
> > the instructions from 
> > http://git-scm.com/book/en/Git-and-Other-Systems-Git-and-Subversion. 
> > Everything appears to run successfully until I get to the 'git svn 
> clone' 
> > command.  I run the command and I get the 'Initialized empty git 
> repository' 
> > message, but none of the expected progress messages afterward.  I'm just 
> > returned to a $ prompt.  Any 'git show' or 'git log' always returns 
> "fatal: 
> > bad default revision 'HEAD'".   I've made sure I have svnserve running 
> as a 
> > daemon and I'm also putting my pre-revprop-change.bat file (just "exit 
> 0") 
> > in the hooks folder with execute permission.  I'm going mad!  I've 
> searched 
> > the web and tried many suggestions.  Can anyone save me some time?  This 
> is 
> > taking way too long.  Thanks. 
>
> I ran into a problem just yesterday trying to set up git-svn on 
> Windows.  A bit of Googleing revealed that there's a bug in the 
> installer of the latest Windows version of Git.  It's just not 
> including all the perl modules that git-svn needs. 
>
> I've heard that there are workarounds, but I personally just installed 
> 1.7.10 and went on my merry way. 
>
> -PJ 
>
> Gehm's Corollary to Clark's Law: Any technology distinguishable from 
> magic is insufficiently advanced. 
>

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
https://groups.google.com/d/msg/git-users/-/2DP6J7JNZUQJ.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
git-users+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/git-users?hl=en.

Reply via email to