HI, All:
    I am a recently setup a git server on mac os ,meanwhile I use a git 
client on ubuntu to do interaction with this git server.
    I have a  code directory(it's very large ,about 1G ) and I did the 
following commands to push it to server side:
          1. cd ~/test
           2. git init
           3. git add .
           4. git commit -m "clean copy for first commit to server"
           5. git remote add origin 
ssh://gitadmin@mylocalgitserver/gitrepos/test
           6. git push origin master

  In the code ,there are some directories which contain some link files 
,something like this:
         > cd asm
         > ls
                 arch             arch-mb86r0x   arch-s3c4510b   config.h   
    ptrace.h
        > ll  st
              
                lrwxrwxrwx  1 gitadmin ubuntu10      11 2012-09-26 14:00 
arch -> arch-sc8810/

       my problem is ,after i finished the step 6 for push ,if i clone ths 
remote repo on server ,i can't see the link file "arch" at all so that i 
can't get a total same code copy as original source.
      But I also did try to make a simple code sample directory which only 
have a directory with one file and a link file to this directory , i can 
commit this code sample to local repo and push it to server side 
successfully ! Then if i checkout the code from remote ,i can get a total 
same code copy: a directory with one file and a link file to this directory 
---- I am totally confused ...
      Is there anyone can help me out?
      

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
https://groups.google.com/d/msg/git-users/-/3oco5vQsWqAJ.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
git-users+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/git-users?hl=en.

Reply via email to