Well, I have more info for the group:

we can execute on server:

# GIT_TRACE=1 git repack

and will receive detailed information about the way of the command:

trace: exec: 'git-repack'
trace: run_command: 'git-repack'
trace: built-in: git 'rev-parse' '--parseopt' '--'
trace: built-in: git 'rev-parse' '--git-dir'
trace: built-in: git 'config' '--bool' 'repack.usedeltabaseoffset'
trace: built-in: git 'pack-objects' '--keep-true-parents' 
'--honor-pack-keep' '--non-empty' '--all' '--reflog' '--unpacked' 
'--incremental' '--delta-base-offset' 
'/apps/acf/git/repo/test_repo/.git/objects/pack/.tmp-19453-pack'
Counting objects: 3, done.
ld.so.1: git: fatal: relocation error: file 
/usr/local/libexec/git-core/git: symbol deflateBound: referenced symbol not 
found

Unfortunately, this information is not enough for me to know what's wrong 
with my git installation.

Have re installed couple times to see if my installation process gives me 
any warning, but none taken.

Please Help.

Thank you.

On Tuesday, October 23, 2012 10:14:03 AM UTC-6, Diego A. Torres wrote:
>
> Hello there, 
>
> May some of you help me to troubleshoot this one?:
>
> Just download and installed packages for Solaris 10, as my server does not 
> have exit to the internet, just follow:
>
>
> https://groups.google.com/forum/?fromgroups=#!searchin/git-users/solaris$20install/git-users/RupbBGmhWTM/R1l_Cyp9KU0J
>
> Now, I can create bare repositories, and everything seems to work well, 
> but when removing the local repository folder and trying:
>
> $ git clone user@server:path/to/repository/repository.git
>
> I get the following error:
>
> error: pack-objects died of signal 9
> error: git upload-pack: git-pack-objects died with error.remote: ld.so.1: 
> git: fatal: 
> relocation error: file /usr/local/libexec/git-core/git: symbol 
> deflateBound: referenced symbol not found
> remote: aborting due to possible repository corruption on the remote side.
> fatal: git upload-pack: aborting due to possible repository corruption on 
> the remote side.fatal: 
> protocol error: bad pack header
>
> also, if i execute in the server:
>
> # cd /path/to/repository/repository.git
> # git repack
>
> I receive the following error:
>
> Counting objects: 3, done.
> ld.so.1: git: fatal: relocation error: file 
> /usr/local/libexec/git-core/git: symbol deflateBound: referenced symbol not 
> found
>
> Here some ideas:
> 1. Which libraries are involved in the package/repackage process?
> 2. Is there a command line process to follow in order to test the package 
> process step by step?
> 3. Is there a verbose mode of the package process so we can see step by 
> step what's happening and debug the process?
>
> Thanks in advance.
>
> Diego.
>

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To view this discussion on the web visit 
https://groups.google.com/d/msg/git-users/-/MwTfYi2nvM0J.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
git-users+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/git-users?hl=en.

Reply via email to