I added a few submodules to my project (I already had some and needed a few 
others) at home and then I tried ran a pull request at work. The only thing 
that happened is that it re-created empty directories with submodules.
git pull
git submodule status
<some sha1 value> bundle/FuzzyFinder
<some sha1 value> bundle/L9
<some sha1 value> bundle/vim-pathogen
<some sha1 value> bundle/vim-powerline
<some sha1 value> bundle/vim-project

All of those directories were empty. I tried running
git submodule update

But nothing happened. Those directories stayed empty.
Can anyone explain why those submodules were not cloned? I had to run
git sumodule init
git submodule update

Only after that I got all my sumodules. Do I have to run git submodule init 
every time I add a new one? My understanding was is that I have to run git 
submodule update. Does anybody know what is the issue? Any help is 
appreciated.

I'm running
Windows XP Pro Version 2002 SP 3
git 1.8.0.msysgit.0

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to