On Friday, October 11, 2013 5:04:59 PM UTC+2, Jordan Flower wrote:

> I'm using Mac OS 10.8.5. In the GitHub Desktop Application I get this 
> error message when I try to commit:
> *Error initializing submodule "repositoryname"*
>> Make sure that the parent repository's .git/config file is writable, then 
>> try again.
> So to back up, I am very new to Git. I am working with someone that added 
> me as a contributor to their repository. So I installed everything (Mac OS 
> 10.8.5) and tried to fumble my way through getting started. I started using 
> the GitHub Desktop Application and it all seemed to be working correctly. I 
> just can't sync and commit. I tried to go back and read all the 
> documentation and open up Terminal and do the whole "git init" for this 
> repository. I succeeded to reinitialize it, which made me feel good despite 
> my lack of command line prowess.
> I've read the documentation, watched the videos, watched third party 
> videos on YouTube and Googled my error message. But I haven't found a thing 
> that helps. 

I imagine that you are contributing to a project that includes submodules, 
which although are working well in normal Git, can be somewhat exotic for 
3rd party toolling, like Github for Mac.

If you have a look at their release notes: 
http://mac.github.com/release-notes.html - you'll see that they have had  a 
number of submodule problems in the past. Perhaps you have discovered a new 
problem there. In any case, please report this with the GitHub for Mac 
team. See their help page here: http://mac.github.com/help.html

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to