----- Original Message ----- 
  From: Michael Laird 
  To: git-users@googlegroups.com 
  Sent: Tuesday, March 25, 2014 5:35 PM
  Subject: Re: [git-users] git clone a directory into a new local directory 
with a new name


  Nelson,
  I am back to all the weirdness I had before.
  I uninstalled Git, downloaded a new copy, and installed it. I did not create 
a new directory under C:\ Program Files\...\apache2\htdocs. I pointed Git Bash 
at the apache2/htdocs directory and entered the command

  git clone git://github.com/angular/angular-seed.git newProject

  I got the message - fatal: destination path 'OPost' already exists and is not 
empty.
  Windows Explorer shows no such directory under apache2/htdocs  htdocs is set 
to show hidden files, and none show up.

  I did a git status on apache2/htdocs
  I got the message - fatal: Not a git repository (or any of the parent 
directories): .git

  While pointed to apache2/htdocs,  I entered cd newProject
  Git Bash came back with  C:/Program Files/.../apache2/htdocs/newProject
  though the newProject directory does not exist in Windows Explorer, and I 
have not typed newProject into this installation of Git until this cd command.

  I did git status at the htdocs/newProject pointer, 
  I get the message - fatal: not a git repository, etc, like the above git 
status in htdocs

  What is messed up? What should I do ?

  On Monday, March 24, 2014 7:39:49 PM UTC-4, Nelson Efrain A. Cruz wrote:
    You're welcome.



    Well you don't need to create any folder, the command will create it, if 
the folder already exists and it's not empty, the command will fail (the 
repository will not be created) but if it's empty there are no trouble.


    With "git clone" you always create a new folder that contains the repo, in 
your case if you are in htdocs the repository will be in newProject, so to run 
git status you need to be inside newProject.







    2014-03-24 16:52 GMT-03:00 Michael Laird <michael...@gmail.com>:

      Nelson,
      Thank you, this is helpful to understand some things.
      Do I make the newProject directory under htdocs before the git clone 
command, or does the git clone command with the newProject at the end make the 
directory?
      When I make the git clone command with newProject, as posted, which 
directory should I have Git Bash pointing to - htdocs or newProject (under 
htdocs)?


      On Monday, March 24, 2014 3:07:58 PM UTC-4, Nelson Efrain A. Cruz wrote:
        the command


git clone git://github.com/angular/angular-seed.git newProject

        its correct, i can only assume that you are having problems with 
positioning in the folders so maybe thats is the problem. Anyway, i think you 
are using git bash, so you can try to run "ls -la" in the htdocs directory to 
se what the git bash is seeing, also in the same folder you can try "ls -la 
newProject/" to see if there is somethin inside.


        Maybe you can give a try to the Git GUI or SourceTree (another GUI) 
from atlassian, but it's better to learn git from the command line first, so 
it's up to you.


        And also you can clone the repository in any folder and then you can 
move the folder to anywhere, lets say in your htdocs folder. In the prompt of 
git bash the default folder is c:\Users\your_user\



        2014-03-24 15:17 GMT-03:00 Michael Laird <michael...@gmail.com>:

          I want to clone a directory of files to start my first AngularJS 
project and put those files in Apache's htdocs directory with the name of my 
project, e.g., newProject. I've used the ProGit book, a bunch of tutorials, and 
Stackoverflow, and after many hours, still don't have it.

          From all my first attempt messing around, I may have 'polluted' my 
git. With no newProject directory in the htdocs directory (ie, after deleting 
prior copies), I point git at htdocs and get a command prompt ending in htdocs. 
There, I can do a cd newProjects and get a new command prompt ending in 
htdocs/newProject, even though the directory does not exist. A git status 
returns fatal:not a git repo (or any of parent directories): .git I have tried 
rm -rf .git at that prompt and get no git response, just another same commmand 
prompt. What's going on? I have recently deleted git, and re-installed a new 
download, so maybe this is no longer an issue.


          When I add a newProject directory to htdocs and do what ProGit says

git clone git://github.com/angular/angular-seed.git newProjectI get 
fatal:destination path newProject exists and is not empty, even though Windows 
Explorer says it is an empty directory, and a git status at that prompt says 
fatal:not a repo (. . .) .git

          When I try the commands at How do you clone a git repository into a 
specific folder? as follows

git clone git://github.com/angular/angular-seed:newProject htdocsI get 
fatal:destination path newProject exists and is not empty A git status at that 
prompt returns fatal: not a repository 

          I have also tried the above command without the htdocs, and get the 
same result.

          Now that I have re-installed a new download of git, I need to do a 
correct command to clone the angular-seed directory of files and get it renamed 
newProject in a directory several levels down in Windows7, called 
apache2/htdos. What do I do?


          -- 

Given you are on Windows 7, do you have any UAC (user access controls) set, 
such that some programes can see the directories and others can't?

I've had a similar problem at my work (large enterprise with big security) 
where the application writes files, but I can't see them.

Philip
--

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to