In Nelson's first response, he suggested doing some ls commands, and I just 
remembered that.
When pointing to the htdocs directory, and I do ls -la
I get - several responses listing directories and files, plus I get 2 
"things" refering to my first attempts last week. They seem to be 
directories as Git sees them (drwxr-xr-x appears for other directories that 
I can see in Windows Explorer), but they are not visible in Windows 
Explorer, even with hidden files made visible. They look like:
 drwxr-xr-x  4 UserName Administ   0  Mar 17  newProject
 drwxr-xr-x  2 UserName Administ   0  Mar 18  newProject1

When I do ls -la newProject
I get similar things in the 'imaginary' newProject directory,  looking like:
drwxr-xr-x  13 UserName Administ  0 Mar 17  newProject
drwxr-xr-x   1  UserName Administ  0 Mar 18  angular-seed

So this explains why I get the error message - fatal: destination path 
'newProject' already exists . . .

What are these "things" that only git is seeing? How do I get rid of them? 
I just did a new install.

On Monday, March 24, 2014 2:17:35 PM UTC-4, Michael Laird wrote:
> I want to clone a directory of files to start my first AngularJS project 
> and put those files in Apache's htdocs directory with the name of my 
> project, e.g., newProject. I've used the ProGit book, a bunch of tutorials, 
> and Stackoverflow, and after many hours, still don't have it.
> From all my first attempt messing around, I may have 'polluted' my git. 
> With no newProject directory in the htdocs directory (ie, after deleting 
> prior copies), I point git at htdocs and get a command prompt ending in 
> htdocs. There, I can do a cd newProjects and get a new command prompt 
> ending in htdocs/newProject, even though the directory does not exist. A 
> git status returns fatal:not a git repo (or any of parent directories): 
> .git I have tried rm -rf .git at that prompt and get no git response, just 
> another same commmand prompt. What's going on? I have recently deleted git, 
> and re-installed a new download, so maybe this is no longer an issue.
> When I add a newProject directory to htdocs and do what ProGit says
> git clone git:// newProject
> I get fatal:destination path newProject exists and is not empty, even 
> though Windows Explorer says it is an empty directory, and a git status at 
> that prompt says fatal:not a repo (. . .) .git
> When I try the commands at How do you clone a git repository into a 
> specific 
> folder?<>as
>  follows
> git clone git:// htdocs
> I get fatal:destination path newProject exists and is not empty A git 
> status at that prompt returns fatal: not a repository 
> I have also tried the above command without the htdocs, and get the same 
> result.
> Now that I have re-installed a new download of git, I need to do a correct 
> command to clone the angular-seed directory of files and get it renamed 
> newProject in a directory several levels down in Windows7, called 
> apache2/htdos. What do I do?

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to