On Tue, 13 May 2014 06:32:28 -0700 (PDT)
Matthew Polder <mpth...@gmail.com> wrote:

> I'm trying to use git to connect to a https server that requires PKI 
> certificates for authentication. I'm running git on RHEL 6.x, so it
> is using the NSS libraries (I believe). 
> When I attempt to clone the git repo on the https server, I get
> * Initializing NSS with certpath: sql:/etc/pki/nssdb
> * NSS error -8018
> I then set the environment variable SSL_DIR to ~/.ssl which does
> change the certpath but I get the same error.

If Git throws the same error, I'd say there are just two possibilities:

* /etc/pki/nssdb is hard-coded to Git (or, rather, supposedly to the
  cURL's code -- Git uses libcurl for HTTP[S] access, and that, in
  turn, uses some backend to do HTTPS -- libnss in your case, it seems).

* This env. variable is not exported so that it's seen in your shell
  but the Git process does not inherit it which causes libnss to
  use the default value for that path.

  What happens if you do

  $ export SSL_DIR="$HOME/.ssl"
  $ git clone ...


You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to