(Thought I posted this already, but don't see it in the group.  Trying 

I was going through the Bitbucket 'getting setup' tutorial and got Git 
(1.9.2) installed on my system (OS X 10.8.5).  That all appeared to be OK; 
I was able to set some configuration items from the command line (email, 
name, etc).  However, when I went to clone the test repository, I got an 
error back:

$ git clone https://bitbucket.org/name/testproject.git
dyld: lazy symbol binding failed: Symbol not found: ___strlcpy_chk
  Referenced from: /usr/local/git/bin/git
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ___strlcpy_chk
  Referenced from: /usr/local/git/bin/git
  Expected in: /usr/lib/libSystem.B.dylib

Trace/BPT trap: 5

Any suggestions?  

I have tried adding things to the path as suggested in a few places.  That 
hasn't apparently helped; both directories listed in the error are in my 
path (at least in the path I get back when I run 'echo $PATH' or look at 
the output of 'env').  I have found some fixes that involved installing 
Xcode and its command line tools; I would like to not have to install an 
entire other software package (or two) just to get Git working.  What does 
Xcode do that makes it work?  A library?  Is that library available 
somewhere else?

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to