On Friday, May 30, 2014 7:15:47 AM UTC+2, Justin Close wrote:
> (Thought I posted this already, but don't see it in the group.  Trying 
> again...)
> I was going through the Bitbucket 'getting setup' tutorial and got Git 
> (1.9.2) installed on my system (OS X 10.8.5).  That all appeared to be OK; 
> I was able to set some configuration items from the command line (email, 
> name, etc).  However, when I went to clone the test repository, I got an 
> error back:
> $ git clone https://bitbucket.org/name/testproject.git
> dyld: lazy symbol binding failed: Symbol not found: ___strlcpy_chk
>   Referenced from: /usr/local/git/bin/git
>   Expected in: /usr/lib/libSystem.B.dylib
> dyld: Symbol not found: ___strlcpy_chk
>   Referenced from: /usr/local/git/bin/git
>   Expected in: /usr/lib/libSystem.B.dylib
> Trace/BPT trap: 5
> Any suggestions?  
> I have tried adding things to the path as suggested in a few places.  That 
> hasn't apparently helped; both directories listed in the error are in my 
> path (at least in the path I get back when I run 'echo $PATH' or look at 
> the output of 'env').  I have found some fixes that involved installing 
> Xcode and its command line tools; I would like to not have to install an 
> entire other software package (or two) just to get Git working.  What does 
> Xcode do that makes it work?  A library?  Is that library available 
> somewhere else?

There's often confusion when installing Git OS X, because Apple ships an 
older version of Git with OS X (or is it with XCode? Can't remember).

In any case, you want to find out which Git is being used, and if it's the 
intended installation. To orient yourself, you have some commands:

which git      # what is the first git executable in your path
git --version  #what version is this pointing at, you'll want this to be 
1.9.2 I suppose
echo $PATH     # what does the whole path look like

Most people on OS X who want a fresh version of Git either install the one 
they download from git-scm.com - or they install it/build it using homebrew 

I believe the git-scm.com installer will end up putting Git in 
/usr/local/git/bin/git, whereas default homebrew will put it in 
/usr/local/bin/git (I haven't got my mac here, so I can't guarantee this).

I think the following happened: You downloaded and ran the git-scm.com 
installer, and something in your environment (OS X version, whatever is 
installed) ended up confusing the installer, and it got some things set up 

While this installer obviously gets a lot of exposure, I'm not sure if it's 
being so well-maintained (seeing how they are lagging a few minor versions 
behind the other installers) for the various upgrades Apple puts out there 
which accidentally breaks stuff. I'm sure people would be grateful if you 
would open a ticket in their 
project: http://sourceforge.net/p/git-osx-installer/tickets/

I suspect most developers out there, myself included, just stick to using 
homebrew these days, as building for your own machine is usually the safest 
thing to do. But using homebrew and building Git still requires you to 
install the XCode command line tools.

Hope this gives you some bearings. Note that I haven't researched this too 
heavily, it's just my feel of what things are like now. Sorry there's not 
an easier way. 

PS: Seems you did some cross posting on 
SO: http://stackoverflow.com/a/23964601 and 
http://stackoverflow.com/a/23964569 - including these for reference.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to