Johannes Sixt <j...@kdbg.org> wrote:

> Am 04.08.2012 00:09, schrieb Michał Kiedrowicz:
> > Junio C Hamano <gits...@pobox.com> wrote:
> >> I do not have strong
> >> opinion on calling this test_seq when it acts differently from seq;
> >> it is not confusing enough to make me push something longer that is
> >> different from "seq", e.g. test_sequence.
> > 
> > I prefer "test_seq" because it reminds seq which helps learning how to
> > use it.  If some other seq feature is ever needed (e.g. increment value,
> > decrementing), it may be added at any time (but I don't think so, there
> > are only few usages after years of test suite existence).
> 
> And the reason for this is that we always told people "don't use seq"
> and they submitted an updated patch. What would we have to do now? We
> have to tell them "don't use seq, use test_seq". Therefore, the patch
> does not accomplish anything useful, IMO.
> 
> The function should really just be named 'seq'.

My reasoning was that there is already test_cmp, so let's make test_seq,
but I agree with you that it doesn't solve the issue completely. So my 2
cents is that it would be best to stay with not allowing seq in the test
suite.

> 
> Or how about this strategy:
> 
> seq () {
>       unset -f seq
>       if ! seq 1 2 >/dev/null 2>&1
>       then
>               # don't have a working seq; provide it as a function
>               seq () {
>                       insert your definition here
>               }
>       fi
>       seq "$@"
> }
> 
> but it is not my favorite.
> 
> -- Hannes
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to