2016-08-16 19:27 GMT+02:00 Junio C Hamano <gits...@pobox.com>:
> Ralf Thielow <ralf.thie...@gmail.com> writes:
>> +
>> +     if (swapped)
>> +             return help_unknown_cmd(cmd);
> I am guilty of suggesting "swapped"; even if we are going to mark
> this as OPT_HIDDEN, I think we should be able to think of a better
> name.  I think the meaning of this boolean is "we know that this is
> not a guide and is meant to be a command.", and I hope we can come
> up with a name that concisely expresses that (e.g. "--not-a-guide",
> "--must-be-a-command").

I think "--cmd-only" is a good name.  With a good name I think it's worth
to make this option visible to the user.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to