Duy Nguyen <pclo...@gmail.com> writes: > On Thu, Feb 1, 2018 at 6:18 AM, Junio C Hamano <gits...@pobox.com> wrote: > ... >> Hmph, how is this new file conceptually different from existing ones >> like CHERRY_PICK_HEAD? > > Conceptually the same, except that CHERRY_PICK_HEAD can't be reused > because it's specifically tied to git-cherry-pick (there's even code > that delete this ref if cherry-pick is run as part of rebase, and > git-status uses this ref to see if a cherry-pick is in progress). > There's also REVERT_HEAD in sequencer.c, same purpose but for > git-revert. Perhaps I should rename this new ref to REBASE_HEAD to > follow the same naming?
I just found "ORIG_COMMIT" too similar to "ORIG_HEAD" that is totally a different thing and feared unnecessary confusion. I think you are correct to suggest that REBASE_HEAD would be more in line with the naming convention with the sequencer-like operations. Thanks.