2013/2/6 Junio C Hamano <gits...@pobox.com>:
> I somehow suspect that this is going in a direction that makes this
> piece of code much less maintainable.
> Look at the entire function and see how many places you do fprintf
> on strings that are marked with _(). short_name and long_name are
> not likely to be translated, but everything else is, especially
> multiple places that show _(opts->help) neither of these patches
> I wonder if it makes more sense to add a helper function that
> returns the number of column positions (not bytes) with a signature
> similar to fprintf() and use that throughout the function instead.
I agree, a helper named 'utf8_fprintf' in utf8.c is better.
I will send a patch latter.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html