From: "Michael Haggerty" <mhag...@alum.mit.edu>
Sent: Thursday, May 30, 2013 10:51 PM
On 05/29/2013 06:53 PM, Junio C Hamano wrote:
Michael Haggerty <mhag...@alum.mit.edu> writes:
+ current_bad_sha1 = xmalloc(20);
+ hashcpy(current_bad_sha1, sha1);
This, together with 18/25, may hint that we want hashdup()?
I thought about it, but was surprised that I could only find one or
other places in the existing code that would use such a function. But
sure, I would be happy to submit a patch.
I think hashdup() needn't be inline, so the definition can't go with
cousins in cache.h. There is no cache.c. So where would be the best
place to define hashdup()? object.c? sha1_name.c?
While I'm at it, I think it would be nice to have constants like
#define SHA1_LEN 20
#define SHA1_HEX_LEN 40
and start using those instead of magic numbers. Any objections (or
suggestions for better names)?
The first named constant should be fully qualified to the same extent as
the second, perhaps:
#define SHA1_BYTE_LEN 20
and perhaps with an alternate of (though HEX is just as good):
#define SHA1_CHAR_LEN 40
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html