On Sat, Jun 08, 2013 at 01:17:28AM +0530, Ramkumar Ramachandra wrote:
> SZEDER Gábor wrote:
> > because nowadays __git_complete_file() is a wrapper around
> > __git_complete_revlist_file().
> What? It was never anything different from a poorly-named alias for
Again: __git_complete_file() has been there since the completion
script was first included in git.
> You have already agreed that
> __git_complete_file() is a horrible name, so why not deprecate it?
I am not against deprecating it, and by "it" I mean the function name.
> Whom is this confusion benefiting, and how is it any "cleaner"?
It's clearer because of the reasons I gave in my other email in the
discussion of the patch.
Plus it would avoid commits on master with incorrect commit messages.
> you're arguing about expanding __git_complete_file(), don't do that:
> just write a new function and give it a proper name.
I am not arguing about that.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html