Jeff King <p...@peff.net> writes:
> On Mon, Jun 10, 2013 at 11:56:33AM -0700, Junio C Hamano wrote:
>> > or similar. I didn't change the name, either. It may be silly to call it
>> > "commit_queue" still since it is now more general. I simply called mine
>> > "queue" (I wanted "pqueue", but that conflicted with globals defined by
>> > OpenSSL; yours is a more general queue anyway, so maybe that is a good
>> > name).
>> I agree that it makes sense not to call it either commit-queue or
>> pqueue. While at it, the filenames should probably be moved as
>> well, no?
> Yeah, definitely. I left all of that as an exercise for you, since the
> name change will involve a lot of fallout in the other patches.
OK, I pushed out a result of some renaming and rebasing. Notable
- The data and API is called prio-queue and they live in prio-queue.[ch];
- The test script is also named test-prio-queue.c, to leave the
door open for other kinds of queue;
- For now, record_author_date() does the obvious read-sha1-file and
- The comparison callback's function signature had three "void *",
so they are named in the header file now. Also two "thing"
pointers are marked as "const void *".
I may have flipped the comparison < vs <= as well.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html