Am 03.08.2013 20:14, schrieb Jonathan Nieder:
> brian m. carlson wrote:
>> cmd_summary reads the output of git diff, but reads in the submodule
>> path into a variable called name. Since this variable does not
>> contain the name of the submodule, but the path, rename it to be
>> clearer what data it actually holds.
I totally agree. Paths and names of submodules are often confused
(especially as they are identical for a submodule that was never
moved), so cleaning up our sources so they use the correct term is
The Right Thing.
But we'll have to use sm_path here (like everywhere else in the
submodule script), because we'll run into problems under Windows
otherwise (see 64394e3ae9 for details). Apart from that the patch
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html