On 2013-08-15 09:00, John Keeping wrote:
> On Wed, Aug 14, 2013 at 06:26:57PM -0500, Tim Chase wrote:
> > On 2013-08-14 12:49, Tim Chase wrote:
> > > If it makes any difference, this is within a cmd.exe shell (with
> > > $PATH set appropriately so git is being found).
> > 
> > Just a follow-up, I tried it within the "bash"ish shell included
> > in the git install and got the same error regarding
> > "/tmp/report.tmp".
> It seems that report.tmp is something that SVN creates and for some
> reason the svn on your system is trying to create it in a Unix style
> temporary directory.
> What happens if you export TMPDIR=C:/Windows/Temp before running
> git-svn?

Still getting the same results.  I tried:

1) cmd.exe with my local temp dir:
 c:\temp> TEMPDIR=%TEMP%
 c:\temp> git svn clone "file:///x:/path/to/repo/trunk/utils/project1"

2) cmd.exe with the windows temp dir as you specify:
 c:\temp> TEMPDIR=c:\windows\temp
 c:\temp> git svn clone "file:///x:/path/to/repo/trunk/utils/project1"

3) git's bash.exe with inline variable definition:
 $ TEMPDIR=c:/Windows/Temp git svn clone 

4) git's bash.exe with exported variable:
 $ export TEMPDIR=c:/Windows/Temp
 $ git svn clone "file:///x:/path/to/repo/trunk/utils/project1"

All of them died with the complaint about "/tmp/report.tmp"

Thanks for the suggestion though.  At least we've determined one
thing that *isn't* the issue ;-)


To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to