On Mon, Aug 26, 2013 at 10:42 AM, Jonathan Nieder <jrnie...@gmail.com> wrote:
> Bruce Korb wrote:
>> $ git svn --version
>> git-svn version (svn 1.7.11)
> Hm.  Two ideas:
>  * Does 1.8.2 or newer work better?  (It contains v1.8.2-rc0~110^2,
>    "git-svn: do not escape certain characters in paths", 2013-01-17,
>    which at first glance looks unlikely to help but might be worth a
>    try.)
>  * Does "git svn clone file://$PWD/private-lustre-svn $PWD/private-lustre-git"
>    work?
> Ciao,
> Jonathan

I get different results:

> $ git svn clone file://$PWD/private-lustre-svn $PWD/private-lustre-git
> Initialized empty Git repository in /u/bkorb/work/private-lustre-git/.git/
> Couldn't open a repository: Unable to connect to a repository at URL 
> 'file:///u/bkorb/work/private-lustre-svn': \
> Unable to open an ra_local session to URL: Unable to open repository 
> 'file:///u/bkorb/work/private-lustre-svn' \
> at /usr/lib/perl5/vendor_perl/5.16.2/Git/SVN.pm line 148.

That makes it look like I didn't get a proper copy of the SVN repo.
Since the real repo lives behind a firewall through two ssh hops,
getting what I need may require learning Subversion instead of using
conversion and familiar tools.....

(I need to extract patch sets for three development branches so I can
apply them to a lustre GIT repo.)
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to