On Sun, Sep 8, 2013 at 1:10 PM, Junio C Hamano <gits...@pobox.com> wrote:
> pull.<someoption> = rebase | merge [| always-fail]
> makes that choice in a clear way, I think.
> Regarding the verb "integrate".
I doubt anybody thinks of pull being an "integration", and even if it
is, it's still doesn't explain what 'integration = merge' means. To be
human friendly you would need to say 'integration-type' or
'integration-kind', or 'integration-mode', then a human would
understand, "oh yeah, the mode I'm using to integrated is a merge, got
But why bother with yet another useless concept the user has to learn?
The user doesn't need to learn about this concept of "integration",
all the user wants is to map:
git pull --rebase
=> pull.<name> = rebase
git pull --merge
pull.<name> = merge
That's it. And my proposed name, 'mode' does the trick just fine.
pull.mode = rebase | merge | merge-no-ff
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html