I'm trying to set a http git server.

I do the following on the git server:
       cd /var/www/html/
git clone --bare  /path/to/dir/ gitproject.git
cd gitproject.git/
mv hooks/post-update.sample hooks/post-update
chmod a+x hooks/post-update

on the local machine run:
git clone http://server.name/gitproject.git

I got the error:
"Initialized empty Git repository in /local/path/gitproject/.git/
fatal: http://server.name/gitproject.git/info/refs not found: did you run
git update-server-info on the server?"

I saw that the file does not exist,  it seem that the file post-update is
not execute.

I run it on the git server:
git update-server-info

Now the info/ref is created.

On local machine I run again :
git clone http://server.name/gitproject.git

Now I get the error:
  Initialized empty Git repository in /local/path/gitproject/.git/
error: The requested URL returned error: 403 (curl_result = 22, http_code
= 403, sha1 = 9d83b83df9fbc75ecd754264f95793fca93ccf93)
error: Unable to find 9d83b83df9fbc75ecd754264f95793fca93ccf93 under
Cannot obtain needed object 9d83b83df9fbc75ecd754264f95793fca93ccf93

What I'm doing wrong?
Any ideas are welcome.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to