Thanks for your answer.

I did not know about "dumb" and "smart" I will read on those in the future.

I found in google that the problem of Error: 403 can be solved.
I run on the git server, in the directory that had the repository: 'git
gc' which do git cleanup and the problem solved.

Thanks you very much.

On 10/10/13 3:06 AM, "Jeff King" <> wrote:

>On Tue, Oct 08, 2013 at 03:05:22PM +0000, Shlomit Afgin wrote:
>> I do the following on the git server:
>>        cd /var/www/html/
>> git clone --bare  /path/to/dir/ gitproject.git
>> cd gitproject.git/
>> mv hooks/post-update.sample hooks/post-update
>> chmod a+x hooks/post-update
>OK, so on the next push, the info/refs file should be updated. Note that
>this file is only necessary if you want to run the "dumb" http protocol
>(i.e., the less efficient one that does not require git on the server).
>You didn't say whether you are trying to set up a "dumb" or "smart"
>git-http server. These days you almost certainly want to set up a
>"smart" one, and you do not need to care about info/refs or running
>> on the local machine run:
>> git clone
>> I got the error:
>> "Initialized empty Git repository in /local/path/gitproject/.git/
>> fatal: not found: did you
>> git update-server-info on the server?"
>> I saw that the file does not exist,  it seem that the file post-update
>> not execute.
>Yes, if you didn't push yet, then it won't have been created.
>> I run it on the git server:
>> git update-server-info
>> Now the info/ref is created.
>OK, good.
>> On local machine I run again :
>> git clone
>> Now I get the error:
>>   Initialized empty Git repository in /local/path/gitproject/.git/
>> error: The requested URL returned error: 403 (curl_result = 22,
>> = 403, sha1 = 9d83b83df9fbc75ecd754264f95793fca93ccf93)
>> error: Unable to find 9d83b83df9fbc75ecd754264f95793fca93ccf93 under
>> Cannot obtain needed object 9d83b83df9fbc75ecd754264f95793fca93ccf93
>403 is an HTTP "Forbidden". Have you configured your web server to allow
>access to the project? Have you marked the repository as
>git-daemon-export-ok, as described in "git help http-backend" (or set
>GIT_HTTP_EXPORT_ALL in the environment)? Is there anything interesting
>in the webserver's error logs?
>If it is still not working after checking those things, can you show us
>how you have configured your webserver (presumably apache?).

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to