On Tue, Nov 26, 2013 at 5:42 AM, Junio C Hamano <gits...@pobox.com> wrote:
> Junio C Hamano <gits...@pobox.com> writes:
>> Perhaps a preparatory patch needs to rename the structure type to
>> object_name_list or something.  And then we can make the variable
>> names, not typenames, responsible for signalling what they mean,
>> i.e.
>>       get_remote_heads(...
>>               struct list_of_objects *extra_have,
>>                 struct list_of_objects *shallow_points);
>> when we introduce the new parameter.
> Yuck, and these are not "list-of-objects", either.  They are
> "list-of-object-names".

I was thinking of renaming it to sha1_array and what do you know, we
do have 'struct sha1_array' with exact same (or better) functionality
that extra_have_objects provides. Will replace extra_have_objects with
current sha1_array.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to