On Mon, Dec 16, 2013 at 4:13 AM, Ramsay Jones
>>>> -static char *vsnpath(char *buf, size_t n, const char *fmt, va_list args)
>>>> +static char *git_vsnpath(char *buf, size_t n, const char *fmt, va_list
>>> :-D I renamed this _from_ git_vsnpath() in commit 5b3b8fa2 ("path.c: Remove
>>> 'git_' prefix from a file scope function", 04-09-2012), because ... well
>>> it's a
>>> file scope function! (i.e. the git_ prefix implies greater than file scope).
>>> I'm not very good at naming things, so ...
>> maybe gitdir_vsnpath() then to avoid the global scope prefix git_?
> Sounds fine to me (but then so does vsnpath ;-) ).
OK I go with this. I think it makes sense
vsnpath -> do_git_path
its three callers are
git_vsnpath -> strbuf_git_path (it's updated to take strbuf)
In the end all these functions have "git_path" in them :)
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html