I forgot to do 'ssh-add', so a 'git fetch' running under Windows Emacs
tried to prompt for the ssh passphrase, could not find an ssh passphrase
prompt program, and aborted.

That left the workspace unusable:

- .git/FETCH_HEAD is empty

    that causes 'git rev-parse FETCH_HEAD' to fail with a confusing
    error message.

- 'git fetch' just hangs after outputting:

remote: Counting objects: 15, done.
remote: Compressing objects: 100% (8/8), done.
remote: Total 9 (delta 5), reused 0 (delta 0)

    even with -v --progress

A fresh clone allowed me to continue working, but this will happen
again, so I'd like a better fix.

The fetch is from stephen_le...@git.savannah.gnu.org/emacs/elpa.git

I'm running git 1.7.9 from Cygwin. I have access to Debian, where I can
compile git and run it under the debugger, if that helps. I have not yet
tried to reproduce this bug on Debian.

-- Stephe

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to