On 2013-12-30 18.07, stephen_le...@stephe-leake.org wrote:
> I forgot to do 'ssh-add', so a 'git fetch' running under Windows Emacs
Windows native emacs or emacs under cygwin ?
> tried to prompt for the ssh passphrase, could not find an ssh passphrase
> prompt program, and aborted.
> That left the workspace unusable:
> - .git/FETCH_HEAD is empty
>     that causes 'git rev-parse FETCH_HEAD' to fail with a confusing
>     error message.
Would you mind to post the "confusion error message" here?
Because some people may find it useful.
> - 'git fetch' just hangs after outputting:
> remote: Counting objects: 15, done.
> remote: Compressing objects: 100% (8/8), done.
> remote: Total 9 (delta 5), reused 0 (delta 0)
>     even with -v --progress
> A fresh clone allowed me to continue working, but this will happen
> again, so I'd like a better fix.
> The fetch is from stephen_le...@git.savannah.gnu.org/emacs/elpa.git
> I'm running git 1.7.9 from Cygwin. 
This feels old, we have v1.8.5.2 as the latest version.

I have access to Debian, where I can
> compile git and run it under the debugger, if that helps. I have not yet
> tried to reproduce this bug on Debian.
This could be helpful:
a) compile git under cygwin (try, and see if the problem is still 
b) Which version of cygwin do you have? 
c) If the same problem exist under Debian, debugging it could be helpfull, yes.
  If the same problem exist here, in some version of git, it would be helpful 
to test
  the latest version of git. (Which means compile & debug)

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to