On Sun, Mar 16, 2014 at 06:30:49PM -0000, Philip Oakley wrote:

> >* jk/branch-at-publish-rebased (2014-01-17) 5 commits
> >- t1507 (rev-parse-upstream): fix typo in test title
> >- implement @{publish} shorthand
> >- branch_get: provide per-branch pushremote pointers
> >- branch_get: return early on error
> >- sha1_name: refactor upstream_mark
> >
> >Give an easier access to the tracking branches from "other" side in
> >a triangular workflow by introducing B@{publish} that works in a
> >similar way to how B@{upstream} does.
> >
> >Meant to be used as a basis for whatever Ram wants to build on.
> To me 'publish' didn't fel right, though the later 'push' suggestion felt
> honest.
> (http://git.661346.n2.nabble.com/RFC-PATCH-format-patch-introduce-branch-forkedFrom-tp7601682p7603725.html)

FWIW, I think I like "@{push}" at this point, and we should perhaps add
"@{pull}" as an alias for "@{upstream}" for consistency.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to