I am running a Mac 10.6.8 and tried to install git-1.9.0 off of the
installer (git-1.9.0-intel-universal-snow-leopard.dmg). The
installation worked fine and gave no error messages. But whenever I
type in a git command (see below for some I tried), it gives me this
error message:
Illegal instruction

I am completely new to git and mostly new of Unix, but here are some
commands I tried:
git help
git config
git init
git clean
git config --global user.name "John Doe"
git status

However, typing "man git" displays typical man pages.
I do not have Xcode installed. (it's very hard to find a legacy copy);
the "make" command also is not present, so I can't use any of the
workarounds I saw listed.
I uninstalled git-1.9.0 successfully using the provided script, then
downloaded the same file again (and installed it) to make sure I
didn't get a corrupt copy. I had the same problem, however.
If I can provide any more information just let me know.
Thanks for any help you can provide.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to