On 04/02/2014 08:58 AM, Torsten Bögershausen wrote:
> On 04/01/2014 05:58 PM, Michael Haggerty wrote:
>> Reduce the amount of code that has to know about the lock_file's
>> filename field.
>> Signed-off-by: Michael Haggerty <mhag...@alum.mit.edu>
>> config.c | 10 +++++-----
>> 1 file changed, 5 insertions(+), 5 deletions(-)
>> diff --git a/config.c b/config.c
>> index 6821cef..1ea3f39 100644
>> --- a/config.c
>> +++ b/config.c
>> @@ -1303,9 +1303,9 @@ static int store_aux(const char *key, const char
>> *value, void *cb)
>> return 0;
>> -static int write_error(const char *filename)
>> +static int write_error(struct lock_file *lk)
> Does the write_error() really need to know about struct lock_file ?
> (The name of the function does not indicate that it is doing something
> with lk)
> And if, would it make sense to rename it into
> write_error_and_do_something() ?
I'm going to leave this part out of the next re-roll, because you are
right: this change is mostly a distraction and probably not an improvement.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html