On Fri, Jun 06, 2014 at 12:00:51AM +0200, Karsten Blees wrote:
> Am 05.06.2014 18:56, schrieb Johannes Sixt:
> > Within mingw.c, if some other function inside mingw.c wants to use
> > mingw_unlink, then it should be written as 'mingw_unlink(foo)', not
> > 'unlink(foo)'.
> I very much like this approach. In fact, we already do this for e.g. 
> mingw_raise.

Hannes, this is consistent with your commit 06bc4b7.  Settled.

> Other callers would typically want the wrapped version (i.e.
> mingw_*).

If this assumption were true, then we have to keep the wrapper macros
defined, both above and below the wrapper function definition.
You are in fact advocating my patch.

Updated version follows.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to