Version 3 of the patch series to cleanup duplicate name_compare()
functions (previously was 'add strnncmp() function' ).
This version goes in a slightly different direction than the previous
version. Before I was trying to add a strnncmp() function so I could
remove duplicate copies of the name_compare() function in tree-walk.c
and unpack-trees.c. But then Torsten Bögershausen pointed out that
there is a cache_name_compare() function which is nearly identical to
* cache_name_compare() is not identical to name_compare(). The former
returns +1, -1, whereas the latter returns +N, -N. But there is no
place where name_compare() was used that needed the magnitude so this
change would not alter its behavior.
So I decided why not generalize the name of cache_name_compare() by
renaming it to name_compare(), since it doesn't do anything with
caches, other than being part of cache.h and read-cache.c. Then the
duplicate name_compare() functions can be removed and the few places
that used cache_name_compare() can be renamed to name_compare().
It cleans up the code with a minimal number of changes. It keeps
existing functions instead of creating new ones. And there are several
other functions in cache.h that are similarly named '*name_compare' so
it follows the already established style.
Also, the name_compare() now uses memcmp() as it did originally instead
of using strncmp() as it did in the last version.
Jeremiah Mahler (5):
cache: rename cache_name_compare() to name_compare()
tree-walk.c: remove name_compare() function
unpack-trees.c: remove name_compare() function
dir.c: rename to name_compare()
name-hash.c: rename to name_compare()
cache.h | 2 +-
dir.c | 3 +--
name-hash.c | 2 +-
read-cache.c | 23 +++++++++++++----------
tree-walk.c | 10 ----------
unpack-trees.c | 11 -----------
6 files changed, 16 insertions(+), 35 deletions(-)
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html