A while ago we discussed refactoring skip_prefix (or adding something
like it) to make it more natural to call. This morning I decided to take
a look at doing this, and went down a rabbit hole of cleanups. This is
part one of the result.
The short of it is that skip_prefix can now be used like this:
if (skip_prefix(arg, "--foo=", &value)
/* arg remains valid if we didn't match! */
if (skip_prefix(arg, "--foo=", &arg))
else if (skip_prefix(arg, "--bar", &arg))
though the latter form is not always useful if the conditional code
wants to see all of "arg".
[01/16]: parse_diff_color_slot: drop ofs parameter
[02/16]: daemon: mark some strings as const
[03/16]: avoid using skip_prefix as a boolean
These ones are preparatory cleanup.
[04/16]: refactor skip_prefix to return a boolean
The actual refactoring; it changes the existing callers at the
[05/16]: apply: use skip_prefix instead of raw addition
[06/16]: fast-import: fix read of uninitialized argv memory
[07/16]: transport-helper: avoid reading past end-of-string
These three are conversions that actually fix bugs.
[08/16]: use skip_prefix to avoid magic numbers
[09/16]: use skip_prefix to avoid repeating strings
These are the straightforward conversions lumped together by the
problem they are solving.
[10/16]: fast-import: use skip_prefix for parsing input
[11/16]: daemon: use skip_prefix to avoid magic numbers
[12/16]: stat_opt: check extra strlen call
[13/16]: fast-import: refactor parsing of spaces
[14/16]: fetch-pack: refactor parsing in get_ack
[15/16]: git: avoid magic number with skip_prefix
These ones are variants of the above two that needed extra
discussion or attention for various reasons.
[16/16]: use skip_prefix to avoid repeated calculations
These ones don't solve a specific problem as the patches above do,
but I think the code ends up more readable.
My conversions are by now means exhaustive. After grepping through all
of the starts_with up to about http.c, I decided to call it a day. But
we can easily convert more as time goes on.
I started from scratch this morning, oblivious to the fact that René
posted something very similar to patch 4 in that thread.
 I test-merged with 'pu'. There is a minor textual conflict with
jk/commit-buffer-length that should be easy to resolve. There's also
one new caller of skip_prefix added in cc/interpret-trailers. It
needs this fix when merged:
diff --git a/trailer.c b/trailer.c
index eaf692b..987fa29 100644
@@ -377,8 +377,7 @@ static int git_trailer_config(const char *conf_key, const
char *value, void *cb)
enum trailer_info_type type;
- trailer_item = skip_prefix(conf_key, "trailer.");
- if (!trailer_item)
+ if (!skip_prefix(conf_key, "trailer.", &trailer_item))
variable_name = strrchr(trailer_item, '.');
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html