Sorry I missed your previous mail.

Please perform the following steps once a new node is added

- Run gsec create command again
    gluster system:: execute gsec_create

- Run Geo-rep create command with force and run start force

gluster volume geo-replication <mastervol> <slavehost>::<slavevol> create push-pem force gluster volume geo-replication <mastervol> <slavehost>::<slavevol> start force

With these steps you will be able to stop/delete the Geo-rep session. I will add these steps in the documentation page(http://gluster.readthedocs.io/en/latest/Administrator%20Guide/Geo%20Replication/).

regards
Aravinda VK

On 08/08/2017 12:08 PM, mabi wrote:
When I run the "gluster volume geo-replication status" I see my geo replication session correctly including the volume name under the "VOL" column. I see my two nodes (node1 and node2) but not arbiternode as I have added it later after setting up geo-replication. For more details have a quick look at my previous post here:

http://lists.gluster.org/pipermail/gluster-users/2017-July/031911.html

Sorry for repeating myself but again: how can I manually delete this problematic geo-replication session?

It seems to me that when I added the arbiternode it broke geo-replication.

Alternatively how can I fix this situation? but I think the easiest would be to delete the geo replication session.

Regards,
Mabi



-------- Original Message --------
Subject: Re: [Gluster-users] How to delete geo-replication session?
Local Time: August 8, 2017 7:19 AM
UTC Time: August 8, 2017 5:19 AM
From: avish...@redhat.com
To: mabi <m...@protonmail.ch>, Gluster Users <gluster-users@gluster.org>

Do you see any session listed when Geo-replication status command is run(without any volume name)

gluster volume geo-replication status

Volume stop force should work even if Geo-replication session exists. From the error it looks like node "arbiternode.domain.tld" in Master cluster is down or not reachable.
regards
Aravinda VK
On 08/07/2017 10:01 PM, mabi wrote:
Hi,

I would really like to get rid of this geo-replication session as I am stuck with it right now. For example I can't even stop my volume as it complains about that geo-replcation...

Can someone let me know how I can delete it?

Thanks



-------- Original Message --------
Subject: How to delete geo-replication session?
Local Time: August 1, 2017 12:15 PM
UTC Time: August 1, 2017 10:15 AM
From: m...@protonmail.ch
To: Gluster Users <gluster-users@gluster.org>

Hi,

I would like to delete a geo-replication session on my GluterFS 3.8.11 replicat 2 volume in order to re-create it. Unfortunately the "delete" command does not work as you can see below:

$ sudo gluster volume geo-replication myvolume gfs1geo.domain.tld::myvolume-geo delete

Staging failed on arbiternode.domain.tld. Error: Geo-replication session between myvolume and arbiternode.domain.tld::myvolume-geo does not exist.
geo-replication command failed

I also tried with "force" but no luck here either:

$ sudo gluster volume geo-replication myvolume gfs1geo.domain.tld::myvolume-geo delete force

Usage: volume geo-replication [<VOLNAME>] [<SLAVE-URL>] {create [[ssh-port n] [[no-verify]|[push-pem]]] [force]|start [force]|stop [force]|pause [force]|resume [force]|config|status [detail]|delete [reset-sync-time]} [options...]



So how can I delete my geo-replication session manually?

Mind that I do not want to reset-sync-time, I would like to delete it and re-create it so that it continues to geo replicate where it left from.

Thanks,
M.



_______________________________________________
Gluster-users mailing list
Gluster-users@gluster.org
http://lists.gluster.org/mailman/listinfo/gluster-users


_______________________________________________
Gluster-users mailing list
Gluster-users@gluster.org
http://lists.gluster.org/mailman/listinfo/gluster-users

Reply via email to