On August 5, 2004 06:34 pm, Derek Atkins wrote: > A few comments.. > > 1) Your changes to app-utils/gnc-ui-common.h and overrides/gnucash > are unwarranted. Also, you've created a commodity.glade in gnome/glade > that conflicts with the commodity.glade in gnome-utils.
Crap. I remember this. For some reason my environment was not set up properly after running ./configure such that the source tree wasn't building. I was meaning to track down/figure this out further but got caught up in coding. It was just easier for me to comment this stuff out. sorry, my bad. > 2) You probably shouldn't use xaccXXX for new names (e.g. xaccBudgetDef) This was an attempt on my part to adhere to the given coding/naming standards as is discussed in one of the coding guideline docs... can't find it now of course. :-) Maybe this doc should reflect the new preferred naming conventions if it doesn't already. > 3) I'm not convinced that gnc_book_get_budgets() (and others of that > ilk) is the right naming convention for your functions... Again modeled after existing code... from Scheduled Transactions I believe. > 4) config.h should never be included in a header file, only in .c files... > This is because config.h is not installed, but the header files are. Oops. how did that get in there. > 5) I'm also unclear that you want to be part of MOD_GUI (e.g. > gnc-budget-cat.c) 6) I'm wondering if there are other budget objects that > want to be QOFified in order to "store" the data.. > Used to ease debugging as I could just turn on/off messages from my part of the engine/gui without getting all the rest. Should have taken that out. I will do that and send an update. > Having said that, it looks good, so I'll try to commit this to CVS > later today. I'll make sure not to commit the pieces I mention in #1 > (but you might want to check your source tree. I'll let you fix the > rest on your own later. :) > Excellent! Once it is in the main tree I will fix some of the above issues and send another patch so that we are working with a smaller change set. Cheers, Darin _______________________________________________ gnucash-devel mailing list [EMAIL PROTECTED] https://lists.gnucash.org/mailman/listinfo/gnucash-devel
