On 17/05/18 17:06, Moritz Lennert wrote:
On 17/05/18 16:43, bonatopa...@libero.it wrote:
Hi all,
I'm new with GRASS GIS and I'm interesting to learn the use of r.fuzzy.*
tools. I read Jasiewicz paper (A new Grass GIS fuzzy inference system
for massive data analys) and I run r.fuzzy.system tool without error.
Now I'm trying to understand the process step by step using r.fuzzy.set
and r.fuzzy.logic. I produced membership raster with r.fuzzy.set but
when I use its outputs to runĀ  r.fuzzy.logic I have the follow error:
ERROR: <accum_abs_high_memb@PERMANENT> is not of type CELL.
The tool requires two input raster data and both are FCELL. I have no
idea where can be the error, both input data are from r.fuzzy.set.
I'm running Grass GIS 7.2.1 in Window 10 and I'm using
spearfish60_grass7 maps.

AFAICT, the message about CELL was an typo (should be FCELL), and one of
the FCELL types was ignored and the module fataled out in any case.
Shows that you are probably the first one to use these modules in a long
time...

I've tried to correct according to my understanding after a rapid
reading of the code. Could you reinstall the module with g.extension and
tell us if the error has been corrected ?

Sorry, just saw that you are on Windows: you will have to wait for the module to be recompiled to get the changes. The latest tomorrow...

Moritz


_______________________________________________
grass-user mailing list
grass-user@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/grass-user

Reply via email to