Hi Rulas,

there can be various reasons, why nxlog isn't allowed to read those files, 
e. g. a kernel security extension like SELinux, AppArmor, or grsecurity 
(with RBAC) to prevent unauthorized access to files.

Please post the output of the following commands:

# namei -l /var/atlassian/application-data/jira/log/atlassian-jira.log
# ps -ef | grep nxlog


Cheers,
Jochen

On Thursday, 15 September 2016 08:35:49 UTC+2, Rulas Mur wrote:
>
> I'm running nxlog as root but its still getting permission denied errors
>
> ERROR failed to open 
> /var/atlassian/application-data/jira/log/atlassian-jira.log;Permission 
> denied
> ERROR apr_stat failed on file 
> /var/atlassian/application-data/jira/log/atlassian-jira.log;Permission 
> denied
>
> Definitely running as root
>
> 2016-09-14 16:40:36 WARNING already running as gid 0
> 2016-09-14 16:40:36 WARNING already running as uid 0
>
> When not running as root I've tried to set the folder and file group to 
> the nxlog group, but still nada.
>
> I've tried just about everthing I can think of. Any ideas?
>

-- 
You received this message because you are subscribed to the Google Groups 
"Graylog Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to graylog2+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/graylog2/dd1431ae-b852-4795-be74-7c01f693a12e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to