On Monday 22 August 2005 23:23, Vincent Guffens wrote: > +# For kern_debug.mod > +kern_debug_mod_OTHERDEP = kern/grub_debug_kern.sym > +kern_debug_mod_SOURCES = kern/kern_debug.c > +kern_debug_mod_CFLAGS = $(COMMON_CFLAGS)
I think it is a really good idea to make a variable for dependencies, but I would suggest a different name for this. Can this be just kern_debug_mod_DEPENDENCIES? > +# take care of the configure arguments > + > +AC_ARG_WITH(debug, [ --with-debug enable some debug mechanisms]) I think it would be better to use AC_ARG_ENABLE with --enable-debug, because --with is used to specify external programs in autoconf. > diff -ru -N -b -B grub2/gendebugkern.sh grub2-backtrace/gendebugkern.sh > --- grub2/gendebugkern.sh 1970-01-01 01:00:00.000000000 +0100 > +++ grub2-backtrace/gendebugkern.sh 2005-08-22 18:47:48.000000000 +0200 > @@ -0,0 +1,14 @@ > +#!/bin/bash Please do not use /bin/bash for portability. It should be: #! /bin/sh > +void EXPORT_FUNC(grub_register_debug_sym) (const char*, void*, grub_size_t); > +void EXPORT_FUNC(grub_unregister_debug_sym) (void *); > +int EXPORT_FUNC(grub_print_debug_sym) (grub_addr_t); > +void EXPORT_FUNC(grub_backtrace) (void); Why do you need to export these functions? Are they used outside the kernel? Okuji _______________________________________________ Grub-devel mailing list [email protected] http://lists.gnu.org/mailman/listinfo/grub-devel
