htgoebel pushed a commit to branch wip-python-build-system
in repository guix.

commit 03b6335595bafbe2f443509feb5aafa350c45c99
Author: Hartmut Goebel <h.goe...@crazy-compilers.com>
Date:   Mon Oct 10 11:13:36 2016 +0200

    gnu: thefuck: Fix build.
    
    Requires setuptools >= 17.1 due to some features used, while our
    python currently only includes 12.0.
    
    * gnu/packages/admin.scm (thefuck): Add setuptools to native-inputs.
---
 gnu/packages/admin.scm |    4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 325c2df..82281d0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1695,6 +1695,10 @@ throughput (in the same interval).")
        ("python-decorator" ,python-decorator)
        ("python-psutil" ,python-psutil)
        ("python-six" ,python-six)))
+    (inputs
+     ;; Requires setuptools >= 17.1 due to some features used, while our
+     ;; python currently only includes 12.0. TODO: Remove this input.
+     `(("python-setuptools" ,python-setuptools)))
     (home-page "https://github.com/nvbn/thefuck";)
     (synopsis "Correct mistyped console command")
     (description

Reply via email to