sharlatan pushed a commit to branch go-team
in repository guix.
commit a7ef0b8db6820d1c5c9f4fab7b01b8220f783ee2
Author: Sharlatan Hellseher <[email protected]>
AuthorDate: Sun Dec 29 22:11:28 2024 +0000
gnu: go-github-com-dpotapov-go-spnego: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-dpotapov-go-spnego): Move from
here ...
* gnu/packages/golang-web.scm: ... to here.
Change-Id: I4c4ab0aa707fe12f82a2393d763f6b5afc266f87
---
gnu/packages/golang-web.scm | 30 ++++++++++++++++++++++++++++++
gnu/packages/golang.scm | 28 ----------------------------
2 files changed, 30 insertions(+), 28 deletions(-)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index cf9da3312e..050e964dcc 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1396,6 +1396,36 @@ Data Representation (XDR) standard protocol as specified
in RFC
4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
(license license:isc)))
+(define-public go-github-com-dpotapov-go-spnego
+ (package
+ (name "go-github-com-dpotapov-go-spnego")
+ (version "0.0.0-20220426193508-b7f82e4507db")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dpotapov/go-spnego")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rpcgzkqhdwfsi8a9f9qar16i663pdx3gvwd6c0vfppy7qjmpjfr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/dpotapov/go-spnego"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-jcmturner-gokrb5-v8
+ go-golang-org-x-net))
+ (home-page "https://github.com/dpotapov/go-spnego")
+ (synopsis "HTTP calls with Kerberos authentication")
+ (description
+ "The package extends Go's HTTP Transport allowing Kerberos
+authentication through Negotiate mechanism (see
+@url{https://tools.ietf.org/html/rfc4559, RFC4559}).")
+ (license license:expat)))
+
(define-public go-github-com-elazarl-goproxy
(package
(name "go-github-com-elazarl-goproxy")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 279dca6cbf..5b54e42ff9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1487,34 +1487,6 @@ configuration file.")
(sha256
(base32 "066bqlgw5h7a3kxswqlv734asb7nw2y6snsn09yqk0ixj23qw22s"))))))
-(define-public go-github-com-dpotapov-go-spnego
- (package
- (name "go-github-com-dpotapov-go-spnego")
- (version "0.0.0-20220426193508-b7f82e4507db")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/dpotapov/go-spnego")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1rpcgzkqhdwfsi8a9f9qar16i663pdx3gvwd6c0vfppy7qjmpjfr"))))
- (build-system go-build-system)
- (arguments `(#:import-path "github.com/dpotapov/go-spnego"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (propagated-inputs (list go-github-com-jcmturner-gokrb5-v8
- go-golang-org-x-net))
- (home-page "https://github.com/dpotapov/go-spnego")
- (synopsis "HTTP calls with Kerberos authentication")
- (description
- "The package extends Go's HTTP Transport allowing Kerberos
-authentication through Negotiate mechanism (see
-@url{https://tools.ietf.org/html/rfc4559, RFC4559}).")
- (license license:expat)))
-
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")