Leo Famulari <l...@famulari.name> writes:

> On Sun, Sep 18, 2016 at 11:07:34PM +0000, ng0 wrote:
>> Hi,
>> why don't we package e2fsprogs-libs? I tried to update it, which fails
>> with a file which apparently got renamed and/or moved into -libs.
>> Is there any reason why e2fsprogs-libs was not packaged?
> Is e2fsprogs-lib a separate package? Or just another distro's method of
> splitting their e2fsprogs package?


> Can you share the work-in-progress patch that causes the problem for
> you?

So far it was just a version bump, tried with 1.43.3 and 1.43, I don't
think I need to send a patch for a disfunctional 2 line change.

> I found this text on the LFS page for the latest release of e2fsprogs
> [0]:
> To set up and run the test suite we need to first link some libraries
> from /tools/lib to a location where the test programs look. To run the
> tests, issue:
> $ ln -sfv /tools/lib/lib{blk,uu}id.so.1 lib
> $ make LD_LIBRARY_PATH=/tools/lib check

I've seen this line in the Gentoo ebuild. But my package failed with

make[2]: *** No rule to make target '../lib/libss.so', needed by 'debugfs'.  
make[2]: *** Waiting for unfinished jobs....
        CC do_journal.c
make[2]: Leaving directory 
make[1]: *** [Makefile:399: all-progs-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-e2fsprogs-1.43.drv-0/e2fsprogs-1.43'
make: *** [Makefile:335: all] Error 2
phase `build' failed after 15.4 seconds

> [0]
> http://www.linuxfromscratch.org/lfs/view/development/chapter06/e2fsprogs.html


Reply via email to