Efraim Flashner <efr...@flashner.co.il> skribis:

> On Wed, Nov 30, 2016 at 09:39:40PM -0500, Mark H Weaver wrote:
>> According to:
>> 
>>   https://hydra.gnu.org/eval/109381?filter=icecat#tabs-removed
>> 
>> the jobs for icecat on armhf and mips64el were removed in evaluation
>> 109381 (corresponding to commit 663d5b5), but were present in the
>> previous evaluation 109380 (commit cd65d60).
>> 
>> Can anyone tell me why this happened?
>> 
>> I guess that the 'supported-systems' field of some package that 'icecat'
>> depends on was recently changed, but I was unable to find anything
>> obvious by grepping through the output of "git log -p".
>> 
>> Debian includes Firefox packages for 'armhf' and 'mips64el', so it's
>> obviously possible to get it working on those platforms.
>> 
>> I find it disturbing that we seem to be in the habit of removing
>> non-Intel systems from 'supported-systems' fields in packages that other
>> distros are able to get working on non-Intel.  These are bugs to be
>> fixed, not swept under the rug to get them out of sight.
>> 
>>       Mark
>
> It turns out libjpeg-turbo depends on nasm, which was incorrectly marked
> as only supporting Intel hardware.

Again, there’s no such problem on current master AFAICS:

--8<---------------cut here---------------start------------->8---
scheme@(guile-user)> ,use(guix)
scheme@(guile-user)> ,use(gnu packages assembly)
scheme@(guile-user)> ,use(gnu packages gnuzilla)
scheme@(guile-user)> (package-supported-systems icecat)
$15 = ("x86_64-linux" "i686-linux" "armhf-linux" "mips64el-linux")
scheme@(guile-user)> (package-supported-systems nasm)
$16 = ("x86_64-linux" "i686-linux" "armhf-linux" "mips64el-linux")
scheme@(guile-user)> (package-transitive-supported-systems icecat)
$17 = ("x86_64-linux" "i686-linux" "armhf-linux" "mips64el-linux")
--8<---------------cut here---------------end--------------->8---

and <https://hydra.gnu.org/eval/109381?filter=icecat>.

Am I missing something?

Ludo’.

Reply via email to