How about 'parse-resolv-conf' for the current feature, and we reserve
'use-system-resolvers' for the feature that Jonathan described?
On Fri, Apr 13, 2018 at 3:46 PM, Willy Tarreau <w...@1wt.eu> wrote:
> Hi Jonathan,
> On Fri, Apr 13, 2018 at 09:24:54PM +0000, Jonathan Matthews wrote:
> > On Fri, 13 Apr 2018 at 15:09, Willy Tarreau <w...@1wt.eu> wrote:
> > > On Fri, Apr 13, 2018 at 08:01:13AM -0600, Ben Draut wrote:
> > > > How about this:
> > > >
> > > > * New directive: 'use_system_nameservers'
> > >
> > > OK, just use dashes ('-') instead of underscores as this is what we
> > > use on other keywords, except a few historical mistakes.
> > I'm *definitely* not trying to bikeshed here, but from an Ops
> perspective a
> > reasonable implication of "use_system_nameservers" would be for the
> > resolution process to track the currently configured contents of
> > resolv.conf over time.
> > AIUI this will actually parse once, at proxy startup, which I suggest
> > should be made more obvious in the naming.
> That's a very good point. Maybe "same-as-resolv-conf" or something
> similar would make it more obvious ?
> > If I'm wrong, or splitting hairs, please ignore!
> Better split hair before features get released and we confuse them all
> the time! There are a few names I'm not proud of you know ;-)