On Mon, Jan 21, 2019 at 03:28:35PM +0100, Frederic Lecaille wrote:
> On 1/19/19 8:53 AM, Willy Tarreau wrote:
> > I was interested in backporting them to 1.8 once we have more experience
> > with them and they're better organized, so that we avoid backporting
> > reorg patches. I'd say we've made quite some progress now and we could
> > possibly backport them. But I wouldn't be surprised if we'd soon rename
> > many of them again since the relation between the level and the prefix
> > letter has to be looked up into the makefile each time, so probably this
> > is something we should improve.
> Note that a "reg-tests-help" makefile target dump the list of LEVELs:

Oh I'm well aware of this and it's where I look this up every time, it's
just that I can't remember them as there's no mnemotechnic mapping, so I
systematically have to look this up.

> We could set the level with strings:
> h*.vtc -> haproxy
> s*.vtc -> slow
> l*.vtc -> low   (perhaps this one should be removed).
> b*.vtx -> bug
> k*.vtc -> broken
> e*.vtc -> exp
> only list of levels could be permitted:
>     $ LEVEL=haproxy,bug make reg-tests ...
> As there is no more level notion here, perhaps we should rename LEVEL
> environment variable to VTC_TYPES, REGTEST_TYPES or something else.

That could be better. Thinking about it further, since run-regtests
already parses the comments at the head of the files to find the
various prerequisites, maybe instead we should get rid of the difference
in the file name and mention the category with a full word as you did
above directly in the files. It would probably be more obvious when
editing these files. The "h*" files could become the default ones
("normal" ? "default" ?) when no category is set, and the other
categories would have to be explicitly mentioned. One benefit is that we
could keep the same naming during initial submission and final merging
when it's related to a bug report or a broken script.

What do you think ?


Reply via email to