Hi Ilya,

On Thu, May 09, 2019 at 12:19:45AM +0500, ???? ??????? wrote:
> Hello,
> 
> does haproxy have some issues when it is built using openssl-1.1.0 and
> running with openssl-1.1.1, for example ?

I don't know. I'd say that openssl guarantees ABI compatibility for low
numbers (as you could theorically build with 1.0.1 and run on 1.0.2) but
I'm not totally sure it's *really* expected to work.

> should we consider such situations in travis-ci openssl matrix ?

I don't think so. We already emit a warning in -vv saying "versions differ"
when this happens and I don't think anyone reasonable will run their
production with this. It can still be convenient for people who need a
quick and dirty proxy to serve as a swiss army knife but it's not what
we need to check for.

Thanks,
Willy

Reply via email to